Add to Company Favorites
Add to My Favorites

GFI MailEssentials for Exchange/SMTP/Lotus


MSRP$20.00
Login for Price
GFI MailEssentials for Exchange/SMTP/Lotus - license + 1 year Software Maintenance Agreement - 1 mailbox

Mfr Part #:
Copied To Clipboard
 Click To Copy
SHI Part #:
Copied To Clipboard
 Click To Copy
Quick Details
  • License + 1 year Software Maintenance Agreement
  • 1 mailbox
  • volume
  • 25-49 licenses
  • Win
GFI MailEssentials for Exchange/SMTP/Lotus
  • License + 1 year Software Maintenance Agreement
  • 1 mailbox
  • volume
  • 25-49 licenses
  • Win
  Additional Details
MSRP: $20.00
Mfr Part #: ME25-49-1Y
SHI Part #: 19538843
Category: Tran security and virus protection
UNSPSC: 43233205
Manufacturer: GFI Software
Product Type: Software Licenses
General Information
CategoryTran security and virus protection
DescriptionGFI MailEssentials for Exchange/SMTP/Lotus - License + 1 year Software Maintenance Agreement - 1 mailbox - volume - 25-49 licenses - Win
ManufacturerGFI Software
MSRP$20.00
UNSPSC43233205
Main Specifications
Header / BrandGFI Software
Packaged Quantity1
Service & Support / TypeNew releases update
Software / License TypeLicense
Software / Volume Pricing Level25-49 licenses
System Requirements / OS RequiredMicrosoft Windows 2000 Advanced Server SP1 or later;Microsoft Windows 2000 Server SP1 or later;Microsoft Windows Server 2003 Enterprise Edition;Microsoft Windows Server 2003 Standard Edition;Microsoft Windows Server 2008;
System Requirements / PlatformWindows
General
Bundled Support1 year Software Maintenance Agreement
CategorySecurity applications - antispam software
PlatformWindows
Product TypeLicense
Licensing
License PricingVolume / 25-49 licenses
License Type1 mailbox
Service & Support
TypeNew releases update - 1 year ¦ Spam filter update - 1 year ¦ Phone consulting - 1 year - availability: business hours ¦ E-mail consulting - 1 year - response time: 1 business day - availability: business hours ¦ Web support - 1 year ¦ Web knowledge base access - 1 year
System Requirements
Additional RequirementsMicrosoft .NET Framework 2.0
Supported OSMicrosoft Windows 2000 Server SP1 or later, Microsoft Windows 2000 Advanced Server SP1 or later, Microsoft Windows Server 2003 Enterprise Edition, Microsoft Windows Server 2003 Standard Edition, Microsoft Windows Server 2008